Nouveau forum : https://forum.slackware-fr.eu.org/

Annonce

29/01/2017 : Ce forum est désormais en lecture seule. Merci d'utiliser le nouveau forum.

13/12/2014 : Inscriptions désactivées pour un moment en raison d'une recrudescence d'inscriptions plus que douteuses.

#1 12-06-2016 19:58:45

ecforum
Membre actif
Date d'inscription: 04-08-2010
Messages: 70

Problème de boot "à froid"

Bonjour,

J'ai installé une slackware 14.2 sur un portable neuf.
Pas de problème.

J'ai essayé de mettre d'autres noyaux mais ça ne boote pas "à froid" :
- si je compile mon noyau, je mets un coup de lilo et je reboote : pas de problème.
- par contre, si j’éteins la machine et que je redémarre, ça va jusqu'au démarrage du boot linux:
  * Decompressiong Linux... Parsing Elf... done
  * Booting the kernel.
puis écran noir, la machine redémarre...

Le kernel d'origine marche.
Le kernel d'origine recompilé par mes soins marche.
Les kernel 4.6.2 et 4.7-rc3 ne marchent pas "à froid".

Le bios est d'une pauvreté rare sur ce portable.
Il était sans système mais avec windows 10 préconisé. Or le bios n'a pas l'option sécure boot qu'il devrait avoir (dans la doc).

Ma question c'est : est-ce que c'est le bios ou la machine qui est en cause (?) ou bien les symptômes vous font penser à quelque chose de connu ?

Si vous avez des idées...

Merci

Hors ligne

 

#2 12-06-2016 21:44:07

ecforum
Membre actif
Date d'inscription: 04-08-2010
Messages: 70

Re: Problème de boot "à froid"

J'ai fini par faire un 4.6.2 qui fonctionne à froid en repartant de la config hugesmp de la slackware et en faisant un make oldconfig sans rien toucher.
Il faudra que je trouve l'option qui pose le pb... sadsad

Une question : le choix du processeur dans la config du kernel, ça sert à la config de gcc pour la compilation (-march, -mtune...) ou ça a un impact sur le kernel ?
La slackware compile en pentium mais ensuite ce sont les drivers intel qui sont chargés, non ?

Bon, ras le bol des compils !

Hors ligne

 

#3 13-06-2016 16:57:09

Didier Spaier
Membre actif
Date d'inscription: 26-04-2013
Messages: 93

Re: Problème de boot "à froid"

ecforum a écrit:

Bon, ras le bol des compils !

Il y a longtemps que j'ai trouvé des façons plus distrayantes de perdre mon temps big_smile

Je préférerais que tu testes slint64-14.2alpha2.

C'est là: http://slackware.uk/slint/x86_64/slint-14.2/iso/

Bon après-midi,

Didier

Hors ligne

 

#4 14-06-2016 02:43:41

Ellendhel
Membre très actif
Lieu: Alexandria, VA - USA
Date d'inscription: 15-08-2008
Messages: 414
Site web

Re: Problème de boot "à froid"

ecforum a écrit:

Une question : le choix du processeur dans la config du kernel, ça sert à la config de gcc pour la compilation (-march, -mtune...) ou ça a un impact sur le kernel ?
La slackware compile en pentium mais ensuite ce sont les drivers intel qui sont chargés, non ?

Hem, non pas vraiement.

Le noyau Linux peut être complilé et exécuté sur une grande variété de plateformes : x86, x86_64, ARM, ... pour ne citer que les plus communes. Comme pour les applications classiques, le noyau ne peut s'exécuter que sur la plateforme pour laquelle il a été compilé.

Donc oui "la slackware compile en pentium" mais cela signifie qu'elle ne peut fonctionner "que sur du pentium". Un noyau x86 fonctionnera sur un PC classique, mais pas sur un Raspberry Pi, et vice-versa.

Les pilotes (drivers) ne sont là que pour les périphériques (carte graphique, carte réseau, ...) une fois que le noyau est correctement chargé.

gcc ne fait que vérifier la valeur du système en cours, pour compiler des programmes sur le système actuel.

Ton portable est normalement un x86 ou plus vraisemblablement un x84_64. Mais ce serait une bonne chose de vérifier. As-tu une référence ou un modèle pour en savoir un peu plus ?

Ou sinon, c'est un grand coup de pas de bol et tu as un composant matériel défectueux...

Hors ligne