Nouveau forum : https://forum.slackware-fr.eu.org/

Annonce

29/01/2017 : Ce forum est dsormais en lecture seule. Merci d'utiliser le nouveau forum.

13/12/2014 : Inscriptions dsactives pour un moment en raison d'une recrudescence d'inscriptions plus que douteuses.

#1 14-05-2015 19:37:46

paniouf
Membre trs actif
Date d'inscription: 13-09-2009
Messages: 225

libcdio-paranoia

Bonjour,

Pb de Downloadhelper : Firefox cherche une libcdio_paranoia alors que le systme possde une libcdio-paranoia.

J'ai t tent, dans un premier jet, de faire un lien libcdio_paranoia ----> libcdio-paranoia , mais  J'ai bien peur que ce soit risqu pour plein d'autres situations o est justement demand libcdio_paranoia .

Peut-tre serait-il plus judicieux d'indiquer directement Firefox de chercher le bon fichier (libcdio_paranoia) , mais je ne vois pas comment procder.

Quelqu'un aurait-il un ide me proposer ?

Merci et bonne fin de journe.


Carte mre : M2A-VM HDMI
CPU : AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
Display : RS690 [Radeon X1200 Series]

Hors ligne

 

#2 14-05-2015 19:42:00

paniouf
Membre trs actif
Date d'inscription: 13-09-2009
Messages: 225

Re: libcdio-paranoia

Erratum : en fait, ce n'est pas Firefox qui a besion de libcdio_paranoia, mais de ffmpeg .

Mais le problme reste l , et probablement pour d'autres situations o est utilis ffmpeg justement.


Carte mre : M2A-VM HDMI
CPU : AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
Display : RS690 [Radeon X1200 Series]

Hors ligne

 

#3 14-05-2015 22:29:19

Didier Spaier
Membre actif
Date d'inscription: 26-04-2013
Messages: 93

Re: libcdio-paranoia

Tu peux donner un exemple avec la commande et le rsultat? Quelle versions de la distribution et des logiciels (et dpendances) concerns?

Merci d'avance et +,

Didier

Dernire modification par Didier Spaier (14-05-2015 22:31:43)

Hors ligne

 

#4 15-05-2015 12:10:34

paniouf
Membre trs actif
Date d'inscription: 13-09-2009
Messages: 225

Re: libcdio-paranoia

Bonjour,

Quand je cherche tlcharger, avec Downloadhelper , une vido de Youtube, la vido ne se charge pas, et voil ce que me dit la petite fentre de Dwhlp :

/usr/bin/ffmpeg: error while loading shared libraries: libcdio_paranoia.so.1: cannot open shared object file: No such file or directory

J'ai bien libcdio-paranoia, mais avec un - et non pas  _, d'o le pb.
La version de Frfx est la 38 (Firefox up to date me dit-il), quant la Slack , c'est la version 14.1 ,X86_64. Voil.


Carte mre : M2A-VM HDMI
CPU : AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
Display : RS690 [Radeon X1200 Series]

Hors ligne

 

#5 15-05-2015 20:54:22

Didier Spaier
Membre actif
Date d'inscription: 26-04-2013
Messages: 93

Re: libcdio-paranoia

Ce n'est pas normal, c'est bien libcdio_paranoia qui est inclus dans Slackware64-14.1:

Code:

/archives/versions/slackware64-14.1/slackware64$ bzgrep libcdio_paranoia MANIFEST.bz2 
-rw-r--r-- root/root       263 2012-07-08 21:25 usr/lib64/pkgconfig/libcdio_paranoia.pc
-rwxr-xr-x root/root     28144 2012-07-08 21:25 usr/lib64/libcdio_paranoia.so.1.0.0
-rwxr-xr-x root/root      1037 2012-07-08 21:25 usr/lib64/libcdio_paranoia.la
/archives/versions/slackware64-14.1/slackware64$ grep libcdio_paranoia /var/log/{packages,scripts}/*
/var/log/packages/libcdio-0.83-i486-1:usr/lib/pkgconfig/libcdio_paranoia.pc
/var/log/packages/libcdio-0.83-i486-1:usr/lib/libcdio_paranoia.so.1.0.0
/var/log/packages/libcdio-0.83-i486-1:usr/lib/libcdio_paranoia.la
/var/log/scripts/libcdio-0.83-i486-1:( cd usr/lib ; rm -rf libcdio_paranoia.so.1 )
/var/log/scripts/libcdio-0.83-i486-1:( cd usr/lib ; ln -sf libcdio_paranoia.so.1.0.0 libcdio_paranoia.so.1 )
/var/log/scripts/libcdio-0.83-i486-1:( cd usr/lib ; rm -rf libcdio_paranoia.so )
/var/log/scripts/libcdio-0.83-i486-1:( cd usr/lib ; ln -sf libcdio_paranoia.so.1.0.0 libcdio_paranoia.so )
/archives/versions/slackware64-14.1/slackware64$

Cela dit tu peux faire ceci, qui n'est qu'un pis-aller:

Code:

ln -s /usr/lib64/libcdio-paranoia.so.1 /usr/lib64/libcdio_paranoia.so.1

Je me demande bien d'o peut venir ton libcdio-paranoia.so.1... la date de cration du fichier peut tre une piste.

PS En fait j'ai la rponse: a vient de Slackware64-current... Tu ne te serais pas tromp de miroir dans /etc/slackpkg/mirrors par hasard? En tous cas Firefox 38 n'est pas inclus dans Slackware64-14.1...

Dernire modification par Didier Spaier (15-05-2015 21:04:53)

Hors ligne

 

#6 15-05-2015 22:01:56

Thom1
Administrateur
Date d'inscription: 21-09-2007
Messages: 524
Site web

Re: libcdio-paranoia

paniouf a crit:

Bonjour,

Quand je cherche tlcharger, avec Downloadhelper , une vido de Youtube, la vido ne se charge pas, et voil ce que me dit la petite fentre de Dwhlp :

/usr/bin/ffmpeg: error while loading shared libraries: libcdio_paranoia.so.1: cannot open shared object file: No such file or directory

J'ai bien libcdio-paranoia, mais avec un - et non pas  _, d'o le pb.
La version de Frfx est la 38 (Firefox up to date me dit-il), quant la Slack , c'est la version 14.1 ,X86_64. Voil.

Salut,

Tu as install ffmpeg depuis un paquet tout prt que tu as trouv ? Ou tu l'as compil toi-mme ? Si tu as pris un paquet tout prt, je te conseille de le compiler toi-mme depuis sbopkg par exemple.

Bonne soire.

Hors ligne

 

#7 16-05-2015 19:34:01

paniouf
Membre trs actif
Date d'inscription: 13-09-2009
Messages: 225

Re: libcdio-paranoia

Bonsoir,

Pour rpondre tout la fois Didier et Thom, je mets rgulirement jour mon systme avec le clbre tryptique : slackpkg -update -install-new -upgrade-all.
En ce qui concerne le dpt , mon choix s'est port sur "ftp://nephtys.lip6.fr/pub/linux/distributions/slackware/slackware64-current/".
Voil peu prs tout ce que je puis dire ce sujet, et je confirme bien avoir la version 38 de Firefox

ls /var/log/packages/ |grep firefox
mozilla-firefox-38.0-x86_64-1

ainsi qu'un libcdio-paranoia

ls /var/log/packages/ |grep libcdio
libcdio-0.93-x86_64-1
libcdio-paranoia-10.2+0.93+1-x86_64-1

et quand je dois charger de nouveaux paquets, je vais les chercher l :

http://slackbuilds.org/

ayant eu effectivement des dboires avec des paquets dj tout compils.
Un mystre pour moi !


Carte mre : M2A-VM HDMI
CPU : AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
Display : RS690 [Radeon X1200 Series]

Hors ligne

 

#8 16-05-2015 19:56:49

Didier Spaier
Membre actif
Date d'inscription: 26-04-2013
Messages: 93

Re: libcdio-paranoia

Ceci confirme que tu n'utilises pas Slackware-64-14.1 mais Slackware64-current.

Cependant, trs probablement, la commande "./configure" du SlackBuild pour ffmpeg 2.1.5 qui comporte l'option --enable-libcdio, recherche libcdio-paranoia et non libcdio_paranoia, d'o l'erreur.

Pour viter ce genre d'erreur l'avenir tu as deux solutions:
1) Tu t'en tiens Slackware64-14.1, version pour laquelle les SlackBuilds http://slackbuilds.org ont t conus et vrifis. Mais maintenant, il ne va pas tre facile d'y revenir...
2) Tu fais toi-mme les modifications ncessaires des SlackBuilds (dpendances comprises, le cas chant) pour les adapter Slackware-current.

Pour information, il n'est pas tonnant que tu rencontres ce genre de problme, sachant qu'une grande partie des paquets, dont de nombreuses librairies y compris libcdio-paranoia, ont t modifis lors de la grande mise jour de Slackware-current date Tue Apr 21 23:44:00 UTC 2015 (cf. le ChangeLog http://www.slackware.com/changelog/curr … cpu=x86_64).

Pour tous: merci de garder en mmoire que les slackbuilds disponibles http://slackbuilds.org ne sont pas prvus pour Slackware-current. Donc dans ce cas vous les utilisez vos propres risques wink

Pour information: cette adaptation des SlackBuilds une nouvelle version ncessite gnralement plusieurs semaines aprs la sortie de la nouvelle version stable. C'est la raison pour laquelle personnellement:
1) Je n'utilise pas -current, sauf justement pour prparer les installateurs et paquets Slint (cf. http://slint.fr/fr/index.html) la version en cours de dveloppement et prparer la nouvelle  version des SlackBuilds que je soumets http://slackbuilds.org
2) Je ne "migre" mon systme de production vers la nouvelle version stable que quand la nouvelle version des SlackBuilds est disponible http://slackbuilds.org.

Dernire modification par Didier Spaier (16-05-2015 20:40:09)

Hors ligne

 

#9 17-05-2015 03:22:42

paradise
Membre trs actif
Lieu: Annecy
Date d'inscription: 04-03-2011
Messages: 453

Re: libcdio-paranoia

Effectivement, il ne sera pas facile de revenir en arrire, surtout cause des bibliothques (libraries en anglais), ou dpendances.

Je ne pourrais plus non plus me passer des Slackbuilds, donc point de current pour ma Slack.

Encore aujourd'hui, quel bonheur d'avoir trouv le Slackbuild du pilote pour ma nouvelle imprimante Epson, je doute que tout se serait bien pass avec le paquet du pilote d'origine, OK j'aime bien bidouiller mais bon.... tongue

Les Slackbuilds m'ont vit bien des soucis depuis que je les utilise ! smile


PC : CM Asus P5Q - CPU Intel Q9650 - RAM 8 Go DDR2 1066 - CG eVga 260GTX 216  - Webcam Hercules Infinite
Portable : Fujitsu A530 (Fedora)
OS : Slackware64 14.1 KDE multilib - Mageia - Openindiana

Hors ligne

 

#10 19-05-2015 13:13:06

paniouf
Membre trs actif
Date d'inscription: 13-09-2009
Messages: 225

Re: libcdio-paranoia

Bonjour,

Merci donc pour vos rponses ; l'absence apparente de rponse vidente et immdiate m'a pouss faire quelques essais, dont avec d'autres vidos sut Ytb, et l, Oh ! surprise, j'ai pu en tlcharger !!!!????
Le problme semblerait donc de venir de cette vido :https://www.youtube.com/watch?v=JY1DjTJAIIc ; donc, tant pis pour elle.


Carte mre : M2A-VM HDMI
CPU : AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
Display : RS690 [Radeon X1200 Series]

Hors ligne